1. Home
  2. Docs
  3. Installation
  4. Framework requirements

Framework requirements

 

In addition to the framework iumio, a standard installation has the following requirements:

 

1. PHP 7.2

Flow was one of the PHP projects taking advantage of namespaces and other features introduced in PHP version 7.2.

By now we started using features of PHP 7.2, so make sure you have PHP 7.2 or later available on your web server.

 

 

2. Lipzip Extensions

Libzip is a C library for reading, creating, and modifying zip archives, you must install Lipzip extensions.

 

3.APCU [PHP DI (production only)]

The apcu is APC stripped of opcode caching.

APCu can provide a compatibility mode, such that it can provide a drop in replacement for the applicable parts of APC.

 

4. Permissions

Please make sure you have the rights permissions to install and access.

 

5. Composer

You must install Composer who is a tool for dependency management in PHP. It allows you to declare the libraries your project depends on and it will manage (install/update) them for you.

 

 

 

 

 

 

6. Internet

To install iumio you must have access to the Internet.

 

7. Webserver

 

In order to install iumio requires some web server software.

Often you will not have a choice of which software to use provider.

Only production. iumio Framework is linked with Framework Internal Server, a reverse proxy for php built-in server

 

 

 

 

 

 

 

 

 

 

Was this article helpful to you? Yes 1 No

How can we help?